Несколько версии php на одном сервере FreeBSD PHP 5.3 , PHP 5.4 , PHP 5.5

Несколько версий PHP могут работать на одном сервере , но лишь одна из них может работать как модуль apache. Я буду ставить версию PHP 5.3 как модуль apache. Вторая будет PHP 5.4 как cgi, третью версию PHP 5.5 поставлю для

Обновление FreeBSD с помощью freebsd-update

Как то хотел обновить порт не помню какой , наткнулся на ошибку … Начал копать и искать проблему оказалось он уже не поддерживал FreeBSD 8.2 пришлось обновлять . Итак начнем , в данном примере есть одно условие , что ядро

Ошибки при сборке php53-extensions

Ошибка /usr/local/include/php/ext/pcre/php_pcre.h:29:18: error: pcre.h: No such file or directory Вылезла ошибка при сборке пакета расширений php53-extensions. Не поставились расширения filter,imap,zip. Причина нет файла pcre.h в /usr/local/include/php/ext/pcre/ Решение: 1cd /usr/ports/lang/php53/ 1make extract Важно посмотреть какую версию вы собирали , в моем